Known issues and bugs with current DICE FC3

Install process

  1. There is a significant pause during the initial install stage while starting up udev. A suitable fix is being worked on.
  2. named error messages pop up while second stage install is installing RPMs, complaining about not having permission to write to the zonefiles. No known ill effect yet. George ??? Believed fixed.
  3. The updaterpms transaction fails on install but continues on regardless quite happily on reboot. This is because of two badly behaved FC3 RPMs which will require fixing upstream or locally. No known ill effect.
  4. A manual reboot is required after the second stage install Fixed.
  5. SCSI installs have yet to be tested. SCSI installs now work.
  6. The installroot (and perhaps the installbase) occasionally hangs - hitting any key will unhang. A /dev/random entropy problem is suspected. Will be fixed.

Environment

  1. Certain things don't work properly unless you copy over at least the /etc/skel/{.bash*,.gtkrc} files to your new NFS homedirs. (This pending the EdENV bash startup technology) No longer relevant now that the EdENV bash startup is now installed.
  2. The graphical GDM theme contains black user feedback text on a dark part of the background image when you make a mistake (user/pass).
  3. When logging in via ssh, you need to enter your password. To be fixed - Tim/Carwyn/Simon? Fixed - providing the sshd has the GSSAPIEnableMITMAttack option set, you can log in from a DICE RH9 machine to a FC3 one. -- sxw

System level

  1. FC3 machines hang on shutdown trying to unmount NFS partitions - suspect this is because rc_network calls rc_netfs regardless of whether rc_netfs was ever started. Brain dead FC3 behaviour that will require fixing. Fixed - amd component wasn't stopping amd daemon !!

Components

  1. Attempting to call component methods (eg, om client status) as a normal user results in No permission to run this method.

Individual RPMS

  1. Firefox won't start up properly if there's no existing .mozilla directory Fixed - firefox needs to register extentions, the rpm was failing to do this from the %post script because $HOME isn't set by om and firefox was segfaulting because it couldn't find one.

-- AlastairScobie - 21 Mar 2005

-- gdmr - 23 Mar 2005

Topic revision: r13 - 13 May 2005 - 16:11:28 - AlastairScobie
 
This site is powered by the TWiki collaboration platformCopyright © by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback
This Wiki uses Cookies