Teaching Software requirements 2019/20

When this project is complete, the final report will appear at TeachingSoftware2019Report

Key

field purpose
Course Course Code
Semester Taught in Semester
Lecturer Course Lecturer
Software Software required for course
Change/no change/new Version changes or new software
Status Upgrade or installation (or not) status
RT RT ticket relating to request
DB Yes if Theon updated with changes

colour meaning
New Software New software required
New Version New software version or checks required
No Change No change this time or all done

Software Requirements

Course Semester Lecturer Software Change/no change/new Status RT
FNLP S2 alex/ht conda (latest) python (latest) nltk (latest) jupyter notebook (latest). NBgrader for marking New marking software required New software required RT:95289 RT:99087
INF2D S2 alex/vbelle haskell (latest), python Check for latest versions of all Checks required RT:95290
PM S1 jeh Matlab (not too particular which one) and Eclipse (Oxygen or later) No changes Nothing required RT:95291
CT S1 cdubach CMake Version 3.4.3 or higher - each student enrolled in the course should have at least 50GB of home directory storage. CMake needs upgraded, check for +50G storage New version of CMake required (we have cmake3 version 3.13.4 installed) RT:95298
ASR S1 pbell1, srenals, hshimoda PyKaldi , Kaldi on on DICE machines and MSc cluster. This could be the latest version, but the version installed last year is also fine. It needs to be compiled against Atlas/OpenBLAS and the openfst library. For the MSc cluster it needs to be compiled to use CUDA. It would be good if the optional IRSTLM package could also be installed. Openfst library needs to have python support (--enable-python config option). Lots of checks and upgrades to latest versions New versions and checks required RT:94841 RT:95501
ILP S1 pbj, stg No longer requires Android Studio 3.4.5, hardware checks for AT-6.06 No longer requires New version of Android, initial setup and general usage slowness mitigation No longer requires New version of Android RT:95420 RT:95427
PDIoT S1 dka Android Studio 3.4.5, Python with scientific libraries (Anaconda or similar) New version of Android, check for anaconda New version of Android RT:95452
IPPO / IJP S1 dcspaul - we are thinking about changing from Eclipse to IntelliJ 2019.1 seems to be current (community edition) https://www.jetbrains.com/idea/features/editions_comparison_matrix.html - Java 11(.03) is the latest LTS. https://www.oracle.com/technetwork/java/javase/downloads/jdk11-downloads-5066655.html - JavaFx 11.02 is the corresponding JavaFx version https://gluonhq.com/products/javafx/ - Scenebuilder 11.0.0 is the corresponding scenebuilder https://gluonhq.com/products/scene-builder/#download - I'll also need whatever is the latest version of BlueJ for IPPO. Gradle 5.4.1. JUnit4 existing version New software, plus new versions of many packages New versions required RT:95907 RT:96053 RT:96058
INF1B / INF1-OP S2 vseeker - we are thinking about changing from Eclipse to IntelliJ 2019.1 seems to be current (community edition) https://www.jetbrains.com/idea/features/editions_comparison_matrix.html - Java 11(.03) is the latest LTS. https://www.oracle.com/technetwork/java/javase/downloads/jdk11-downloads-5066655.html - JavaFx 11.02 is the corresponding JavaFx version https://gluonhq.com/products/javafx/ - Scenebuilder 11.0.0 is the corresponding scenebuilder https://gluonhq.com/products/scene-builder/#download - I'll also need whatever is the latest version of BlueJ for IPPO. Gradle 5.4.1 JUnit4 existing version New software, plus new versions of many packages New versions required RT:95907 RT:96053 RT:96058
DME S2 aonken Python (version 3.5 or later) with NumPy , SciPy , Matplotlib, Pandas, Seaborn and Scikit-learn (latest); Jupyter-Notebook (latest) Check for latest versions Checks required RT:95961
TSPL S1 wadler agda, agda-mode, agda-stdlib last-minute updates - done! also requires stack upgrade, implied GHC updates RT:97536
CCS S1 clucas2 Matlab latest stable No changes Nothing required RT:97486
AV S2 rbf Matlab latest stable No changes Nothing required RT:97499
AGTA S2 kousha Matlab latest stable No changes Nothing required RT:97537
MLPR S1 imurray2 Matlab latest stable No changes Nothing required RT:97539
NAT S1 mherrman Matlab latest stable No changes Nothing required RT:97540
IVR S1 skhadem ROS, OpenCV , PyCharm   PyCharm Done, OpenCV3 installed, 4 built and waiting; ROS ongoing... RT:97051
INF2B S2 hshimoda Matlab latest stable No changes Nothing required RT:97787
CS S2 marapini pycrypto No changes Double-check python3 only RT:99027

-- RichardBell - 17 May 2019

Topic revision: r21 - 28 Nov 2019 - 09:02:53 - RichardBell
 
This site is powered by the TWiki collaboration platformCopyright © by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback
This Wiki uses Cookies