Teaching Software requirements 2015/16

Key

field purpose
Course Course Code
Semester Taught in Semester
Lecturer Course Lecturer
Software Software required for course
Change/no change/new Version changes or new software
Status Upgrade or installation (or not) status
RT RT ticket relating to request
DB Yes if Theon updated with changes

colour meaning
New Software New software required
New Version New software version or checks required
No Change No change this time

Software Requirements

Course Semester Lecturer Software Change/no change/new Status RT DB
CT S1 cdubach no requirements no change nothing to do RT:72677 unk
IJP S1 dcspaul bluej (version >= 3.1.1), eclipse (version >= 4.2), evince (version >= 2.28.2), java (version >= 1.8.0), javafx_scenebuilder (version >= 2.0) Changes required See about eclipse 4.4 RT:72678 RT:70900 unk
CP S1 jcb Awaiting full response Awaiting full response Awaiting full response RT:72676 unk
DS S1 rsarkar networkx python library 1.9.1 required if possible Underway RT:72679 unk
SDP S1 ht Opencv Arduino IDE VLC Xawtv, Minicom, Ross, DiCE based video streaming and recording service New software required Graham/Garry looking at this RT:72681 unk
MLP S1 srenals python-2.7 and recent versions of numpy (ideally 1.9.2) and matplotlib (ideally 1.4.3). Changes required numpy is a regression from SL6 RT:72682 unk
CG S1 tthorne GLFW (latest) GLEW (latest) Changes required GLEW will be installed on SL7 machines from next Thursday, GLFW evaluation as of next Thursday. RT:72683 unk
MLPR S1 imurray Matlab, python, numpy, scipy, matplotlib -- "latest" Changes required Need to check for latest versions RT:72685 unk
INF2D S1 alex pl (version >= 5.7.11) Changes required 5.10.2 is Being Tested on SL7 RT:72691 unk
INF1-OP S1 perdita Eclipse >=4, Java latest Changes required building the latest for SL7. RT:72701 unk
SEOC S1 perdita Eclipse >=4, Java latest Changes required building the latest for SL7, possible new online assessment RT:72700 unk
DDS S2 ewan interactive notes using Ipython notebook / Jupyterhub. New software required pip3 install jupyterhub (within a virtualenv) when I try to run it I get an error : Failed to find proxy ['configurable-http-proxy'] The proxy can be installed with `npm install -g configurable-http-proxy` RT:72704 unk
COMN S1 mlee23 VirtualBox: the default version, the COMN linux VM image that has Dummynet software package Checks required Need to check image RT:72704 unk
-- RichardBell - 25 Aug 2014
Edit | Attach | Print version | History: r21 < r20 < r19 < r18 < r17 | Backlinks | Raw View | Raw edit | More topic actions...
Topic revision: r18 - 17 Jul 2015 - 11:55:01 - RichardBell
 
This site is powered by the TWiki collaboration platformCopyright © by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback
This Wiki uses Cookies