Plone Tips

A collection of hopefully helpful tips on using Plone (at the moment more from a managing/technical point of view, rather than a users point of view, but we should have one of those too).

That's it for now, feel free to add to it.

User Run Plone

The Zope and Plone RPMs are not installed on all DICE machines, if you want to run your own Plone site on a non-priviledge port, then:

  • first get the RPMS installed by added the dice/options/plone.h header and run updaterpms.
  • decide where you want the root of the Zope instance to live, eg /disk/zope, /home/user/foo/, but where ever it is you'll need to consider if the zope process will be able to access it once the users credentials have expired.
  • use /usr/lib/zope/bin/mkzopeinstance.py (give it the -h if you want to see help) with out arguments it will prompt for a directory to create the Zope instance home in (see above), and an administrator username and password. (this should be done by the user who is going to be running the process)
  • This will have created a file structure rooted in the specified directory eg in /disk/zope/. To start the instance run /disk/zope/bin/zopectl start or one of the other scripts in there, and check what other options they take.

That should be it, your instance will be running on http://localhost:8080/. If you want to change things like enabling debugging mode or the port it listens on, then look at /disk/zope/etc/zope.conf

/disk/zope/Products/ would be the place to put additional Products, for example if you are setting up a clone of the main wcms.inf.ed.ac.uk site, then you could copy the /usr/lib/zope/Products directory to here.

When Product things go wrong

This assumes you can get to the ZMI for the affected site.

I've had cases when installing a Product from the Plone "Site Setup" control panel has left the site broken, ie you get a Python error message. Hopeing that uninstalling the product will fix it, go to the ZMI for the site, eg localhost:8080/<site>/manage/ and look for portal_quickinstaller, you'll be able to uninstall the Product from there.

When Skin things go wrong

Change to a new skin also break things some times, leaving the site unaccessible, again go to the ZMI for the site and look for portal_skins and click the properties tab. At the bottom of that page you see what skin the site is currently using, and can change it back to what was working previously, eg Plone Default.

-- NeilBrown - 09 Jun 2009

Edit | Attach | Print version | History: r4 < r3 < r2 < r1 | Backlinks | Raw View | Raw edit | More topic actions...
Topic revision: r1 - 09 Jun 2009 - 10:43:41 - NeilBrown
 
This site is powered by the TWiki collaboration platformCopyright © by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback
This Wiki uses Cookies