TWiki> DICE Web>SL7ServicesServersUpgrade (revision 8)EditAttach
Zapped defunct content and replaced with simple list of SL6 machines still to go:

host description notes
alexandria old mediasrv turned off
arachne Secure AFS web server roger
babbler Informatics Jabber server - KVM guest on oyster, in Forum server room roger
barb git and gerrit craig
tench git server craig
collins CUPS server craig
borges backup print server craig
tetrakvm kerberised CUPS server craig
crunchie "Mail: Main Informatics Mail Server" neil
kegan Room Booking Server neil/craig
knox cvs/svn.inf roger
sanremo Bugzilla server bugzilla.inf.ed.ac.uk neil
lammasu Fileserver and private AFS server for npt neil
mariona redmine kill/gordon?
drip web.inf.ed.ac.uk neil
fantoosh SL6 homepages and wiki server neil - Planning on VM'ing but needs 100GB
nescd2 NESC web server - KVM neil
toaster Web: groups.inf web server neil
wafer Web: www.inf.ed.ac.uk and various Institutes neil - Planning on VM'ing but will need 200+GB just for data
canny DR Web: www.inf.ed.ac.uk and various Institutes neil - Planning on VM'ing but will need 200+GB just for data
20    

SL7 machine total = 68

Notes

VM space

For the services we are planning on VM'ing. The current free space on the VMhosts are:

Forum
girassol - 130GB
gaivota - 1000GB
azul - 16GB + 950GB
KB
amarela - 480GB
vermelha - 650GB

Are MPU happy for me to grab 300GB from gaivota and 200GB vermelha?

Apache 2.4

Though apache 2.4 ships with a compatibility module to allow old style "allow/deny" and the new "require host" directives. The recommendation is that you don't mix and match those directives. Indeed I had problems debugging access problems when trying to use both, so I've been simply disabling the compatibility module !apacheconf.moduleactive_access_compat mSET(no) to force only the new "require" way. Any .htaccess or config that then contains the old access directives throws an apache error.

For the main web servers, homepages, groups, www. The plan will be (ahead of time) to update config something like:

  <IfVersion < 2.4>\n
  order deny,allow\n
  deny from all\n
  </IfVersion>\n
  <IfVersion >= 2.4>\n
  Require all denied\n
  </IfVersion>\n

And provide docs on computing.help for users.

-- NeilBrown - 05 Jun 2017

Edit | Attach | Print version | History: r12 | r10 < r9 < r8 < r7 | Backlinks | Raw View | Raw edit | More topic actions...
Topic revision: r8 - 12 Jun 2017 - 16:37:10 - NeilBrown
 
This site is powered by the TWiki collaboration platformCopyright © by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback
This Wiki uses Cookies